The SimpleInvoices forum has moved to Google Plus - this forum is now read-only
zend mail protocol exception: permission denied
  • alexfurtadoalexfurtado September 2012

    I can not send e-mail with invoice . Please some one help.

    zend mail protocol exception: permission denied

  • mattmatt September 2012

    What settings do you have in the config with respect to mail?

    Outback Australia
  • alexfurtadoalexfurtado September 2012

    Matt thank you but i got it.
    email.host = smtp.gmail.com
    email.smtp_auth = true
    email.username = [email protected]
    email.password = mypassword
    email.smtpport = 465
    email.secure = ssl
    email.ack = false

  • johnny2000johnny2000 January 2013

    I am getting the same error, I have similar config on the config.ini, but I still receive the same error. Please help me. Thank you.

  • mattmatt January 2013

    same error is likely same issue

    recheck your mail settings in the config file
    Post them so that we can look if you like
    (don't show real password or username though)

    Outback Australia
  • johnny2000johnny2000 January 2013

    email.host = smtp.gmail.com
    email.smtp_auth = true
    email.username = [email protected]
    email.password = mypassword
    email.smtpport = 465
    email.secure = ssl
    email.ack = false

  • mattmatt January 2013

    What are your PHP mail settings?
    In particular do you have for SMTP settings in your PHP info

    Outback Australia
  • johnny2000johnny2000 February 2013

    this is in the php.ini mail function settings:
    [mail function]
    ; For Win32 only.
    ; http://www.php.net/manual/en/mail.configuration.php#ini.smtp
    SMTP = smtp.gmail.com
    ; http://www.php.net/manual/en/mail.configuration.php#ini.smtp-port
    smtp_port = 465

    ; For Win32 only.
    ; http://www.php.net/manual/en/mail.configuration.php#ini.sendmail-from
    sendmail_from = [email protected]

    ; For Unix only. You may supply arguments as well (default: "sendmail -t -i").
    ; http://www.php.net/manual/en/mail.configuration.php#ini.sendmail-path
    sendmail_path = /usr/sbin/sendmail -t -i

    ; Force the addition of the specified parameters to be passed as extra parameters
    ; to the sendmail binary. These parameters will always replace the value of
    ; the 5th parameter to mail(), even in safe mode.
    ;mail.force_extra_parameters =

    ; Add X-PHP-Originaiting-Script: that will include uid of the script followed by the filename
    mail.add_x_header = On

    ; Log all mail() calls including the full path of the script, line #, to address and headers
    ;mail.log =


    For phpinfo:
    sendmail_path /usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i
    serialize_precision 100 100
    short_open_tag Off Off
    SMTP smtp.gmail.com smtp.gmail.com
    smtp_port 465 465


    By the way on the php.ini, it says that the smtp/port option is for Win32 only. For unix like or linux it is the sendmail_path.

Categories