The SimpleInvoices forum has moved to Google Plus - this forum is now read-only
Reports pages does not work
  • January 1970 Edit

    None of the Reports pages display, all i see is a white page.

    I had this with previous version as well. Right now I have latest 2008 version, I am running it on localhost.
    Thanks in advance for any insight you can give me.

  • justinjustin March 2008

    Hey Zuze,

    are you running the latest version of Simple Invoices on the exact same PC?

    - if so let me know the details of your system
    - ie. Win XP, using WAMP or XAMPP, etc..

    there was some changes to the version of the reports lib were using so it might not be happy with your setup

    Cheers

    Justin

    SmarterInvoices.com :: Simple Invoices hosting | Kelly.org.au :: Simple Invoices custom development | justin.kelly.org.au
  • zuzezuze March 2008

    Hi Justin... reports have never worked for me, old or new version. Everything else works just fine. It has to do something with local server.

    I am running it on mac OS X
    MAMP
    PHP/5.2.0
    MySQL client version: 5.0.33
    phpMyAdmin - 2.9.2

    I am waiting for my webshost to upgrade to PHP 5 so I can run it on commercial webserver.

  • justinjustin March 2008

    ok thanks

    for reports php5-xsl needs to be installed you can check ./phpinfo.php - but if its MAMP it should be installed already

    note: we use phpreports ( http://phpreports.sourceforge.net/how.html ) to do reports

    cheers

    justin

    SmarterInvoices.com :: Simple Invoices hosting | Kelly.org.au :: Simple Invoices custom development | justin.kelly.org.au
  • bluemistbluemist March 2008

    hi,

    I have almost the same setup. Mamp on OSX and no reports are produced.
    the page is blank, but some source is generated.

    if I can do anything to help, let me know. would like to have the reports working

    Dean

  • justinjustin March 2008

    hey guys

    if your on mamp there may be a small mod you need to make

    refer: http://simpleinvoices.org/wiki/using_simple_invoices_on_bsd_or_darwin?s=reports

    note: the file in question may have changed location so just you may have to search for it

    note: i haven't tested this fix so no idea if it does work

    cheers

    justin

    SmarterInvoices.com :: Simple Invoices hosting | Kelly.org.au :: Simple Invoices custom development | justin.kelly.org.au
  • bluemistbluemist March 2008

    thanks this was helpful.

    the file to change is
    /simpleinvoices/library/phpreports/PHPReportsUtil.php

    change WIN in the first function to BSD

    /******************************************************************************
    * *
    * This function will return if there is a PHPReports path in the PHP *
    * ini_get("include_path"). *
    * *
    ******************************************************************************/
    function getPHPReportsIncludePath(){
    $aPaths = explode((stristr(PHP_OS,"WIN")?";":":"),ini_get("include_path"));
    foreach($aPaths as $sPath)
    if(stristr($sPath,"phpreports"))
    return $sPath;
    return null;
    }


    that fixed it for me.


    dean

  • justinjustin March 2008

    Thanks Dean

    good to hear it works

    Cheers

    Justin

    SmarterInvoices.com :: Simple Invoices hosting | Kelly.org.au :: Simple Invoices custom development | justin.kelly.org.au
  • ReliefAshamaReliefAshama January 2013

    Old thread -- I have this problem on Debian GNU/Linux (wheezy). php5-xsl is installed. I see only the following reports:

    Statement of Invoices
    Monthly Sales and Payments per Year

    All the rest produce bare pages.

Categories